Outage
Incident Report for Cargo Forwarder
Resolved
This incident has been resolved.
Posted Apr 20, 2023 - 13:38 UTC
Investigating
We are currently investigating this issue.
Posted Apr 20, 2023 - 13:29 UTC
This incident affected: API and App Store.